Kun nuo kapsi.fi asennusohjeet ovat vanhoja, nii voisiko saada neuvoa Djangon asennuksesta?

Edit:

Olen asentanut webapp palvelimelle pythonin virtuaaliympäristön, johon asenin djangon ja gunicornin. Tämän jälkeen loin django projektin www hakemistoon ( pitääkö olla siellä?). Tämän jälkeen loin lakan puolella samaiseen kansioon .htaccess tiedosto jossa on seuraava sisältö:

RewriteEngine On RewriteRule ^(.*)$ http://webapp1.kapsi.fi:XXXXX/$1 [P]

Tämän jälkeen käynnistän gunicorin avulla django serverin webapp serverillä komennolla: gunicorn hello.wsgi:application --bind webapp1.kapsi.fi:XXXXX

Serveri näyttäisi olevan pystyssä, mutta kun yritän webselaimella mennä kyseiseen kansioon "xxx.kapsi.fi/hello, mitään ei näy. Nyt teen jotain väärin tässä. Osaisiko joku vähän jeesaa tässä?

Avainsanat:
muokattu 26.05.2018 klo 01:47
pinq's gravatar image pinq kysyi
12.05.2018 klo 01:12
326, hyväksyttyjä vastauksia: 0%

Huomioi, että tuo pitää olla sisäiseen porttiin bindattuna, eli webapp1.n.kapsi.fi on sisäinen osoite ja lakalta sitten rewrite tohon sisäiseen osoitteeseen. Tai vaihtoehtoisesti myös voi proxyn tehdä apachen avulla. En nimittäin ole varma onko rewrite hyvä idea tuohon tarkoitukseen koska Lakalla pitää olla reverse-proxy jotta pääset käsiksi tuohon webapp1:n sisäiseen porttiin ulkoa.

muokattu 04.06.2018 klo 15:54
ikilinkki
samip537's gravatar image samip537 vastasi
04.06.2018 klo 15:50
564, hyväksyttyjä vastauksia: 25%
1

Ongelma tosiaan korjaantui kun lisäsi tohon rimpsuun sen n:än eli webapp1.n.kapsi.fi. Ylläpidolta sain jo portin käyttöön jonka kautta pyyntö ohjataan webapp1 serverille. Ajattelin jossain vaiheessa tehdä jonkunlaiset ohjeet tästä, jotta muiden ei tarvi samalla tavalla tapella tästä...

(04.06.2018 klo 16:06) pinq

Miten toi proxyn tehdän apachen avulla ( tai linkki johonkin ohjeeseen), kun ite kokeilin tehdä apachella, nii herjaa vaan että toiminta ei ole sallittu.

(20.12.2018 klo 11:17) pinq

Sain toimimaan lopulta. Ollut mielessä, että voisin kirjoitella jossain välissä rautalankaohjeet tähän.

ikilinkki
Asiz's gravatar image Asiz vastasi
20.12.2018 klo 12:29
214, hyväksyttyjä vastauksia: 0%

Pystytkö antaa mitään pikasta vinkkiä, missä mulla mättää vai onko tämä isompi prosessi?

(03.01.2019 klo 15:07) pinq

Tämän ja muutaman muun ketjun perusteella selvitin miten homma tehdään ja kirjoitin ohjeen:

https://github.com/suniala/kapsi-django-ohje

Ohjeessa pitäisi olla kaikki tarvittava lukuun ottamatta sovelluspalvelimen ajamista taustalla. Ottaisin mieluusti vastaan vinkkejä millaisella cron-loitsulla sovelluspalvelin kannattaisi käynnistää. Ja muutakin palautetta voi pistää joko täällä tai githubissa.

ikilinkki
kosmik's gravatar image kosmik vastasi
09.02.2019 klo 17:28
313, hyväksyttyjä vastauksia: 0%

Keksin cron-loitsutkin, ks. github.

(15.02.2019 klo 20:56) kosmik

Toimii hienosti, kiitos näistä ohjeista! Itse en tosin tuota django-wikiä asentanut, vaan hieman soveltaen generoin django-adminilla sen perus mysite-esimerkkiprojektin. Olin tämän takia jo vaihtamassa Kapsia vps-hostaajaan, mutta nytpä ei tarvitsekaan. :-)

(17.03.2019 klo 17:06) ppuo

Lataako teillä Django etusivun oikein? Minulla kun osoitteeksi syöttää domain.fi tai domain.fi/home/, yrittää sivusto mennä osoitteeseen domain.fi/index.html/ ja tulee herja sivua ei löydy. Kaikki muut templatet kyllä latautuu oikein.

Käytän siis gunicornia Djangon pyörittämiseen webapp1:llä, yllä mainitulla tavalla. Static-kansion sisältöä pyörittää Whitenoise niminen python ohjelma. Onko tämä nyt kiinni Apachen asetuksista vai mistä?

muokattu 26.08.2018 klo 18:16
ikilinkki
Asiz's gravatar image Asiz vastasi
26.08.2018 klo 18:15
214, hyväksyttyjä vastauksia: 0%

Saitko koskaan toimimaan?

(20.12.2018 klo 11:15) pinq

Sainb lopulta. Onkin ollut mielessä, että voisin jossain välissä kirjotella rautalankaisen ohjeen tähän.

(20.12.2018 klo 12:30) Asiz

Jos viitit. Oon nyt yrittänyt vääntää djangoa toimimaan webapp palvelimella ja oon pääsyt jo aika pitkälle, mutta jostain syystä sä ei löydä index.html tiedostoa tai mitään muutakaan tiedostoa, minkä luon. Djangon virheilmoitus kyllä tulee. Jokin siis menee vielä pileen eteenpäin ohjauksessa.

(20.12.2018 klo 12:37) pinq

Hei ja sori kun vastaaminen kesti. Minkä virheilmoituksen django antaa?

Olethan huomannut lisätä webapp:n osoitteen ja käyttämäsi domainin osoitteen settings.py-tiedoston ALLOWED_HOSTS-kohtaan? Esimerkki: "ALLOWED_HOSTS = ['webapp1.n.kapsi.fi', '.esimerkkidomain.fi', '.esimerkkidomain.fi.']"

Lisäksi lisää settings.py tiedostoon kohta "USE_X_FORWARDED_HOST = True"

ikilinkki
Asiz's gravatar image Asiz vastasi
06.01.2019 klo 22:18
214, hyväksyttyjä vastauksia: 0%

Juu noi kaikki on siellä, mutta väittää että ei löydä sivua. Kun luon ihan uuden projektin ja käynnistän serverin tolla gunicorn käskyllä ja yritän mennä sivulle, nii herjaa että index sivua ei ole "Request URL: http://pinq.kapsi.fi/index.html". Jos yritän mennä admin sivulle, niin se ohjaa http://pinq.kapsi.fi/admin/ sivulle. Itse toi .htaccess tiedosto on polussa http://pinq.kapsi.fi/DjangoOhjelma/. Jotenkin toi ohjaus ei mene oiken nyt.

(07.01.2019 klo 14:05) pinq

Näköjään jos laitan .htaccess tiedoston www juureen, nii kaikki toimii. mut heti kun laitan ohjauksen jostain kansiosta, nii se ei enää toimi. Jotenkin nyt ei uudelleen ohjaus toimi djangossa tai .htaccessä on jokin asetus pielessä

(14.01.2019 klo 10:48) pinq

Sinun vastauksesi

näytä/piilota esikatselu

Tarkkaile kysymystä

Sähköpostitse:

Kirjautumisen jälkeen voit tilata tähän kysymykseen jätetyt uudet vastaukset ja kommentit omaan sähköpostiisi.

RSS-lukijan kautta:

Pelkät vastaukset

Vastaukset ja kommentit

Markdown-perusteet

  • *kursiivi* tai _kursiivi_
  • **lihavointi** tai __lihavointi__
  • linkki:[teksti](http://url.com/ "otsikko")
  • kuva?![alt teksti](/path/img.jpg "otsikko")
  • numeroitu luettelo: 1. Foo 2. Bar
  • Lisätäksesi rivinvaihdon kirjoita kaksi välilyöntiä rivin loppuun.
  • Tavallisemmat HTML-tagit toimivat myös.

Kysymyksen avainsanat:

×7
×3

kysytty: 12.05.2018 klo 01:12

katsottu: 1,281 kertaa

päivitetty: 17.03.2019 klo 17:06