4
1
Oisko mahdollista saada ohjetta kuinka asennetaan Owncloud kapsin siiloon?
Avainsanat:
mihatsu's gravatar image mihatsu kysyi
14.01.2013 klo 02:10
53115, hyväksyttyjä vastauksia: 0%

« edellinen1234seuraava »

PHP 5.3.4 vaatimus on poistettu. Eli taas toimii.

ikilinkki
Smoo's gravatar image Smoo vastasi
14.05.2013 klo 13:31
102, hyväksyttyjä vastauksia: 0%

Tuleeko tuo secure-www:n juuren .htaccessiin vai lisätäänkö sama myös owncloud-hakemiston .htaccessiin? No samapa tuo, asennus pysähtyy aina "Viimeistele asennus" -napin painamisen jälkeen. Selain jää tyhjäksi. Versio on 5.0.8.

ikilinkki
sundelstr%C3%B6m's gravatar image sundelström vastasi
13.07.2013 klo 20:13
0, hyväksyttyjä vastauksia: 0%

Kaipaisin myös apuja. Yritin asentaa 5.0.8:n tuolla kolmiksen ohjeella, mutta eihän se noin vaan mene. Setup-ruudusta saan syötettyä admin tunnuksen ja salasanan ja polun siiloon, mutta sen jälkeen homma tyssää pelkkäään tyhjään ruutuun.

owncloudin loki sanoo näin:

{"app":"PHP","message":"xcache_clear_cache(): xcache.admin.user and\/or xcache.admin.pass settings is not configured. Make sure you've modified the correct ph p ini file for your php used in webserver. at \/var\/www\/userhome\/tunnus\/sites\/tunnus.kapsi.fi\/secure-www\/owncloud\/lib\/util.php#853","level":4,"time

Mutta millä pääsee kiinni php.iniin vai pääseekö?

ikilinkki
jv_'s gravatar image jv_ vastasi
13.07.2013 klo 21:04
121, hyväksyttyjä vastauksia: 0%

Vastaan itse itselleni, eli tällainen ohjeistaa ensin kommentoinmaan xcachen pois käytöstä kokonaan: https://github.com/owncloud/core/issues/3417

Se ei kuitenkaan vielä riitä, sillä util.php ei noudata configia vaan tarkistaa xcachen olemassa olon suoraan. Kommentoimalla vielä tuon 853 rivin util.php:stä siksi aikaa, että configin tallennus menee läpi saa asetukset paikoilleen. Sen jälkeen util.php:n voinee palauttaa ennalleen, jos sille on tarvetta. Ei pitäisi olla, koska cache.php:n muokkauksen pitäisi poistaa alunperinkin koko xcache pois käytöstä.

(13.07.2013 klo 21:33) jv_

Yrirtin asentaa 5.0.10-version, En saanut toimimaan. Piti asentaa 4.5.13 http://download.owncloud.org/community/owncloud-4.5.13.tar.bz2

ikilinkki
Kestosippi's gravatar image Kestosippi vastasi
20.08.2013 klo 23:55
17819, hyväksyttyjä vastauksia: 0%

Itse käytän 5.0.10. Päivityksen jälkeen piti juurikin tuota ./lib/util.php:ta muokata. Itse kommentoin ulos rivin 854. (853:n poisto aiheutti toisen virheen)

cache_clear_cache(XC_TYPE_VAR, 0); --> //xcache_clear_cache(XC_TYPE_VAR, 0);

ikilinkki
Smoo's gravatar image Smoo vastasi
21.08.2013 klo 08:02
102, hyväksyttyjä vastauksia: 0%

5.0.9 -> 5.0.10 rikkoi myös mun owncloud asennuksen, logeissa xcache herjaa. Tuolla on vielä lisää aiheesta:

https://github.com/owncloud/core/issues/3417

Tein nämä

"No, this is still a problem in 5.0.9. The update again failed. the workaround (deleting line 36 in lib/cache.php) was still necessary to complete the update to 5.0.9."

"Still not working for update to 5.0.10. Now you also have to delete lines 853-858 in lib/util.php to avoid a white page after update."

Niin toimii taas.

muokattu 21.08.2013 klo 23:53
ikilinkki
obi's gravatar image obi vastasi
21.08.2013 klo 23:52
113, hyväksyttyjä vastauksia: 0%

Miten owncloudin clientin saa toimimaan?

Webbisivu toimii hyvin, mutta clienttien uppi ei toimi (lataus toimii), tulee vain "Forbidden". (Palvelinversio on 5.0.12, ja clientit 1.4.2)

ikilinkki
timppa's gravatar image timppa vastasi
12.11.2013 klo 11:49
112, hyväksyttyjä vastauksia: 0%

Mä lisäsin tuon .htaccess-jutun sekä domainin juureen sekä itse owncloud-hakemiston .htaccess tiedostoon (jos se ei siellä jo ollut, en muista). Sen jälkeen myös clientti pelaa molempiin suuntiin.

(12.11.2013 klo 12:21) jontto

Ei toimi minulla, vaan tulee "Internal Server Error". Ilman tuota riviä htaccessissa www sivun kautta toimii, mutta tuon rivin kanssa ei.

(19.11.2013 klo 16:37) timppa
1

Sain viimein toimimaan kun asensin seuraavat rivit .htaccessiin:

IndexIgnore * <limit get="" post="" put="" delete="" options="" propfind="" proppatch="" mkcol="" copy="" move="" lock="" unlock=""> Order allow,deny Allow from all </limit>

(19.11.2013 klo 19:21) timppa

Mulla on owncloud 6.0 asennettuna ja se toimii hienosti selaimessa. Clienteissä on sitten synkkaus ongelma. Mac osx client antaa 403 forbidden ilmoituksen, kun lisää tietokoneen owncloud hakemistoon jotain. Eli se ei lataudu serverille. Käytössä on secure-www ja siilo owncloud-data hakemisto. Onko kyse palvelimen vai clientin asetuksista?

ikilinkki
laspe's gravatar image laspe vastasi
02.03.2014 klo 19:57
111, hyväksyttyjä vastauksia: 0%

Yritin asentaa uusimman 7.01-version. Toimii, mutta tolkuttoman hitaasti. Piti ottaa vanhempi 6.04-versio, joka pelaa hienosti. Mikähän siinä mättää? Asensin puhtaan uuden asennuksen MySQL-versiona.

ikilinkki
Kestosippi's gravatar image Kestosippi vastasi
09.08.2014 klo 12:04
17819, hyväksyttyjä vastauksia: 0%

Asensin myös 7.0.1 -version peruskonffiksella eli sqlitellä. Webclient toimii mutta en saa ubuntun nautilusta tahi natiiviclienttiä ottamaan yhteyttä, vaikka säädin .htaccess asetuksia sekä secure-www että owncloud hakemistoissa. Toisaalta, ketjussa mainittu sftp:// -protokollakaan ei mun härveliltä toimi.

ikilinkki
rmickos's gravatar image rmickos vastasi
10.08.2014 klo 12:39
111, hyväksyttyjä vastauksia: 0%

Sinun vastauksesi

näytä/piilota esikatselu

Tarkkaile kysymystä

Sähköpostitse:

Kirjautumisen jälkeen voit tilata tähän kysymykseen jätetyt uudet vastaukset ja kommentit omaan sähköpostiisi.

RSS-lukijan kautta:

Pelkät vastaukset

Vastaukset ja kommentit

Markdown-perusteet

  • *kursiivi* tai _kursiivi_
  • **lihavointi** tai __lihavointi__
  • linkki:[teksti](http://url.com/ "otsikko")
  • kuva?![alt teksti](/path/img.jpg "otsikko")
  • numeroitu luettelo: 1. Foo 2. Bar
  • Lisätäksesi rivinvaihdon kirjoita kaksi välilyöntiä rivin loppuun.
  • Tavallisemmat HTML-tagit toimivat myös.

Kysymyksen avainsanat:

×5
×5

kysytty: 14.01.2013 klo 02:10

katsottu: 13,616 kertaa

päivitetty: 01.05.2017 klo 03:21