0

SASL tunnistautuminen Freenode IRC-verkossa

Jostain syystä SASL tunnistautuminen ei toimi minulla lakalta. Seurasin ohjetta Configuring SASL for irssi

[Freenode] -!- Irssi: Connection to chat.freenode.net established
[Freenode] !adams.freenode.net *** Looking up your hostname...
[Freenode] !adams.freenode.net *** Checking Ident
[Freenode] !adams.freenode.net *** Found your hostname
[Freenode] !adams.freenode.net *** Got Ident response
[Freenode] -!- Irssi: CLICAP: supported by server: account-notify
          extended-join identify-msg multi-prefix sasl
[Freenode] -!- Irssi: CLICAP: requesting: multi-prefix sasl
[Freenode] -!- Irssi: CLICAP: now enabled: multi-prefix sasl
[Freenode] -!- Irssi: SASL authentication failed
[Freenode] -!- Irssi: SASL authentication aborted

Kokeilin kummallakin PLAIN ja DH-BLOWFISH mekanismilla.

Onko mahdollista debugata tuota? Toimiiko jollain tuo?

Markos's avatar
431
Markos
asked 2014-03-18 16:43:56 +0200, updated 2014-03-18 16:44:38 +0200
edit flag offensive 0 remove flag close merge delete

Comments

add a comment see more comments

1 Answer

0

Ilmeisesti ongelman aiheutti se, ettei minulla ollut käytössä certifikaatit SSL yhteydessä. Minulla oli kyllä aikaisemmin SSL yhteys palvelimelle, josta merkkinä oli +Z mode käyttäjätunnuksella.

Configuring Client SSL Certificates for Irssi ohjeen perusteella sain SASL:n toimimaan.

Markos's avatar
431
Markos
answered 2014-05-19 16:59:10 +0200
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments

Your Answer

Login/Signup to Answer