0

ownCloudin päivittäminen

Yritän päivittää owncloudia versiosta 7.0.3 versioon 7.0.4. Saan seuraavan virheilmoituksen error.logiin:

[Thu Dec 11 08:13:54 2014] [warn] [client 62.237.220.3] mod_fcgid: read data timeout in 120 seconds, referer: /index.php/apps/updater/update.php [Thu Dec 11 08:13:54 2014] [error] [client 62.237.220.3] Premature end of script headers: php5.fcgi, referer: /index.php/apps/updater/update.php

Miten tuota timeouttia voisi kasvattaa tilapäisesti päivityksen ajaksi? Google neuvoisi että IPCCommTimeoutille pitäisi asettaa suurempi arvo .htaccessissa, mutta ilmeisesti sitä ei voi asettaa käyttäjätason oikeuksilla:

[Thu Dec 11 08:02:25 2014] [alert] [client 62.237.220.3] .htaccess: IPCCommTimeout not allowed here

Kokeilin myös kasvattaa maxexecutiontime ja maxinputtime -muuttujien arvoja php.inissä, mutta siitä ei ollut apua. Varmistin vielä erikseen phpinfolla että asetukset menivät perille. Viimeksi kun päivitin 7.0.2->7.0.3 niin noiden kahden kasvattamisesta oli apua - tai sitten kävi vaan hyvä tuuri.

laiti's avatar
31
laiti
asked 2015-01-06 21:05:31 +0200, updated 2015-01-06 21:06:22 +0200
edit flag offensive 0 remove flag close merge delete

Comments

add a comment see more comments

2 Answers

2

Millä tapaa päivität owncloudia? Itselläni olen vain ladannut uusimman paketin wgetillä ja purkanut sen tar komenolla jolloin se ylikirjoittaa ohjelmatiedostot.

tommis's avatar
121
tommis
answered 2015-01-21 15:34:09 +0200
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments
0

Isot kiitokset vinkistä! Olen päivittänyt sen ihan web-UI:n kautta tähän asti, nyt kokeilin tuota komentorivimetodia ja sillä meni läpi sukkana.

laiti's avatar
31
laiti
answered 2015-01-21 22:03:40 +0200
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments

Your Answer

Login/Signup to Answer