1

Sähköpostihälytys SSH-kirjautumisesta

Terve

Tuli hauska idea että laittaisin jonkinlaisen hälytyksen lähtemään sähköpostilla varotoimenpiteenä aina kun joku (toivottavasti minä) kirjautuu tunnukselleni. Tämähän onnistuu helposti lisäämällä esimerkiksi jotain tämän kaltaista komentotulkin asetustiedostoon.

echo "SSH LOGIN\n$USER@$(hostname -f)\n$(date)\n$SSH_CLIENT" | mail -s "SSH LOGIN $USER@$(hostname -f)" käyttäjä@sähköposti.fi

Edellinen lähettää tämän muotoisen sähköpostin aina kun tunnukselleni kirjaudutaan:

Subject: SSH LOGIN käyttäjä@lakka.kapsi.fi

SSH LOGIN
käyttäjä@lakka.kapsi.fi
Wed Feb 17 00:01:30 EET 2016
xxx.xxx.xxx.xxx xxxxx 22

Ongelmana tässä tavassa on se että nyt kun käynnistää esimerkiksi tmuxin, screenin tai vastaavan ohjelman ja availee sillä muutaman "ikkunan", lähtee jokaisesta komentotulkin käynnistymisestä sähköposti menemään.

Onko edes mahdollista tehdä tätä ilman pääkäyttäjän tunnuksia niin että vain silloin kun uusi SSH-yhteys muodostetaan, lähtisi sähköposti menemään?

ollran's avatar
77
ollran
asked 2016-02-17 02:24:38 +0200
edit flag offensive 0 remove flag close merge delete

Comments

add a comment see more comments

1 Answer

1

Kokeile laittaa tuo sähköpostia lähettävä skriptisi tiedostoon .bash_profile sen sijaan, että laittaisit sen tiedostoon .bashrc. Näin skripti ajetaan vain ja ainoastaan kirjautumisen yhteydessä eikä uuden shellin luomisen yhteydessä.

arimartti's avatar
439
arimartti
answered 2016-02-20 18:51:30 +0200
edit flag offensive 0 remove flag delete link

Comments

Unohdin mainita että käytän Zsh-komentotulkkia. Kokeilin Bashilla ja näköjään tuo toimii siinä. Tosin skriptini ei näköjään toimi Bashilla kunnolla koska Bash ei suoraan tulkitse `\n` -merkintää rivinvaihdoksi. Sehän korjautui kun antoi `echo`lle parametrina `-e`. echo -e "SSH LOGIN\n$USER@$(hostname -f)\n$(date)\n$SSH_CLIENT" | mail -s "SSH LOGIN $USER@$(hostname -f)" käyttäjä@sähköposti.fi Kokeilin Zsh:lla laittaa skriptin vuorollaan `~/.zshenv`, `~/.zprofile` ja `~/.zlogin` -tiedostoihin, mutta Zsh suorittaa ne kaikki käynnistymisen yhteydessä. Joten täytyy kai vaihtaa Bashiin.

ollran's avatar ollran (2016-02-21 12:49:18 +0200) edit

Hetkinen, ei tuo toimi sittenkään. Heti kun vaihdoin Bashin oletuskomentotulkiksi, alkoi sekin lähetellä viestejä jokaisesta uudesta ikkunasta jonka avaan tmuxilla. Ratkaisu voisi olla se että asettaisin tmuxin käynnistämään toisen komentotulkin ja käyttäisin vaikka Bashia oletuskomentotulkkina.

ollran's avatar ollran (2016-02-21 13:18:46 +0200) edit
add a comment see more comments

Your Answer

Login/Signup to Answer