0

PHP-versio! VAROITUS?

  • retag add tags

PHP-versio?

Varoitus PHP-versiosi, 5.6.38-0+deb8u1, saa tällä hetkellä vain tietoturvapäivityksiä PHP-projektilta. Tämä tarkoittaa, että PHP-versiotasi ei tueta enää pitkään. Suosittelemme siirtymistä uudempaan PHP-versioon ennen kuin sen tuki loppuu kokonaan 31.12.2018. Joomla toimii nopeammin ja turvallisemmin uudemmalla PHP-versiolla (PHP 7.x suositellaan). Ota yhteyttä palveluntarjoajaasi päivityksen suhteen.

Jorma's avatar
394
Jorma
asked 2018-12-09 14:02:37 +0200
edit flag offensive 0 remove flag close merge delete

Comments

Loppuukohan Joomlani toiminta kokonaan tämän vuoksi?

Jorma's avatar Jorma (2018-12-09 14:03:30 +0200) edit
add a comment see more comments

7 Answers

0

@lakka:~$ php -version PHP 7.2.12-1+0~20181112102353.11+jessie~1.gbp55f215 (cli) (built: Nov 12 2018 14:04:20) ( NTS ) Copyright (c) 1997-2018 The PHP Group Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies with Zend OPcache v7.2.12-1+0~20181112102353.11+jessie~1.gbp55f215, Copyright (c) 1999-2018, by Zend Technologies

rapularaimo's avatar
203
rapularaimo
answered 2018-12-10 21:28:46 +0200, updated 2018-12-10 21:30:51 +0200
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments
0

OHO! Kapsilla on siis uusi PHP-versio. Mitäköhän mun pitäisi tehdä että Joomla löytäisi oikean versiotiedon?

=============

Järjestelmätiedot

php: Linux web3 4.14.79-grsec-kapsi #2 SMP Sun Nov 11 12:40:47 EET 2018 x86_64

dbserver: mysql

dbversion: 5.5.5-10.0.37-MariaDB-0+deb8u1

dbcollation: utf8generalci

dbconnectioncollation: utf8mb4generalci

phpversion: 5.6.38-0+deb8u1

server: Apache/2.4

sapi_name: cgi-fcgi

version: Joomla! 3.9.1 Stable [ Amani ] 27-November-2018 15:00 GMT

platform: Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT

useragent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko)

Chrome/70.0.3538.77 Safari/537.36

Jorma's avatar
394
Jorma
answered 2018-12-11 00:02:23 +0200, updated 2018-12-11 00:18:14 +0200
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments
0

https://www.kapsi.fi/tiedotteet/#449

Löysin tiedotteenkin aiheesta ja yritin toimia ohjeen mukaisella komennolla huonolla menestyksellä.

Tuo mainittu komento teki sites-hakemiston php5-xxxxxxxx.kapsi.fi.fcgi tiedostoon polun php7-versiolle mutta eipä Joomlani enää toiminut sillä. Kun muutin sen polun takaisin muotoon: #!/usr/bin/php5-cgi niin sivustoni toimii jälleen.

(Harmi etten ottanut talteen sitä polkua joka tuossa oli silloin kun ei toiminut)

Jorma's avatar
394
Jorma
answered 2018-12-11 01:14:44 +0200
edit flag offensive 0 remove flag delete link

Comments

Laita sen tilalle tämä: #!/usr/bin/php-cgi7.2 niin pitäisi toimi php7.2:lla. :)

samip537's avatar samip537 (2018-12-11 18:03:41 +0200) edit

Ei se ala sillä toimimaan viiveelläkään. Sivun vasempaan ylänurkkaan tulee vain sana ERROR

Jorma's avatar Jorma (2018-12-11 22:08:27 +0200) edit
add a comment see more comments
0

Joo, ei löydy ko. ohjelman lisäämää tiedostoa.

Eli se kirjottaa ko. tiedoston poluksi näin: /usr/bin/php-cgi7.2

ls /usr/bin/php-cgi7.2

ls: cannot access /usr/bin/php-cgi7.2: No such file or directory

Myöskään whereis tai locate ei löydä mitään järjellistä.

rapularaimo's avatar
203
rapularaimo
answered 2018-12-11 14:33:48 +0200
edit flag offensive 0 remove flag delete link

Comments

Ei kuuluisikaan lakalla löytyvän. Tuo löytyy vain web-backendin tiedostojärjestelmästä tuosta polusta.

samip537's avatar samip537 (2018-12-11 18:05:37 +0200) edit

Löytyy vain web-backendistä tuolla nimellä ja polulla.

samip537's avatar samip537 (2018-12-11 18:07:01 +0200) edit

Onko web-backend sama kuin webapp1.kapsi.fi?

rapularaimo's avatar rapularaimo (2018-12-11 20:21:53 +0200) edit
add a comment see more comments
0

Ratkaistu:

Ylläpito korjasi tilanteeni! Kiitos! Vika oli tietokannan vanhanmallisessa "salasanamuotoilussa". Joomla ei saanut php7.2 tilassa yhteyttä tietokantaan. Vanhalla php5.6 "salasanamuotoitu" toimii mutta ei enää uudella php7.2 ohjelmalla.

Jorma's avatar
394
Jorma
answered 2018-12-15 13:30:32 +0200, updated 2018-12-15 13:34:47 +0200
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments
0

Tietokannan salasanamuoto korjaantuu seuraavalla ylläpidon ohjeella:

Voit myös korjata itse ongelman MySQL-komennolla kirjautumalla esimerkiksi lakalta sisään palvelimelle:

mysql -u usernametahan -p

mysql> SET PASSWORD FOR 'usernametahan'@'%' = PASSWORD('salasanatahan');

(poistuu mysql-ohjelmasta komennolla quit)

Huomaa että tässä nuo kaikki heittomerkit, sulkeiset sekä lopussa puolipiste kuuluu komentoon mukaan (mutta tuo mysql> on vain järjestelmän komentokehote)

Jorma's avatar
394
Jorma
answered 2018-12-15 17:06:14 +0200, updated 2018-12-15 17:07:38 +0200
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments
0

Warning: session_start(): Failed to read session data: user (path: /var/lib/php/sessions) in /var/www/1/-----------------/sites/------.kapsi.fi/www/libraries/joomla/session/handler/native.php on line 260 Error: Failed to start application: Failed to start the session

Tämmöisen virheilmon saan jos laitan PHP7.2 käyttöön ja yritän jotain Joomlan sivua käynnistää.

Jorma's avatar
394
Jorma
answered 2018-12-13 20:58:53 +0200, updated 2018-12-13 21:00:31 +0200
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments

Your Answer

Login/Signup to Answer