1

.htaccess forward sovelluspalvelimelle

Hei,

muutokset jälkeen en ole saanut sovelluspalvelinta(gunicorn) näkymään ylos. Minulla on ollut htaccessilla ohjaus sille tähän tyyliin:

RewriteEngine On
RewriteCond %{REQUEST_URI} !^/static
RewriteCond %{REQUEST_URI} !^/.well-known
RewriteRule ^(.*)$ http://webapp1.n.kapsi.fi:53678/$1 [P]
(portti vaihdetttu)

mutta ei vaan yhdistä. Sivut näkyvät hienosti jos ottaa ssh putken ja menee suoraan localhost:portti

Bysmyyr's avatar
196
Bysmyyr
asked 2017-02-28 11:30:38 +0200
edit flag offensive 0 remove flag close merge delete

Comments

add a comment see more comments

3 Answers

1

Oletko saanut tähän mistään apua? Minulla on samankaltainen ongelma webapp1:ssä pyörivän Tomcatin kanssa. Palvelin kuuntelee porttia PORTTI (itse väliltä 30000–40000 arpomani luku) ja sites-hakemiston syövereissä on tällainen .htaccess:

RewriteEngine On
RewriteRule ^(.*)$ http://webapp1.n.kapsi.fi:PORTTI/$1 [P]

Apachen lokiin tulee tuon rewriten sisältävään hakemistoon tehdyistä pyynnöistä tämänlaista virhettä:

[Sat Mar 25 19:01:43.060860 2017] [proxy:error] [pid 31532:tid 4086969440000] (111)Connection refused: AH00957: HTTP: attempt to connect to 10.0.0.177:PORTTI (*) failed
[Sat Mar 25 19:01:43.060940 2017] [proxy_http:error] [pid 31532:tid 4086969440000] [client 89.27.78.90:61319] AH01114: HTTP: failed to make connection to backend: webapp1.n.kapsi.fi

Aivan vastaava konffi toimi vielä ennen helmikuista verkkosivu-uudistusta. Silloin Tomcat pyöri kirsikalla.

Olen kysynyt apua ylläpidolta, mutta sieltä ei ole kuulunut minkäänlaista vastausta.

kekkis's avatar
101
kekkis
answered 2017-03-25 21:04:48 +0200, updated 2017-03-25 21:15:31 +0200
edit flag offensive 0 remove flag delete link

Comments

Nyt viimein ylläpito vastasti. Kuulemma palomuuriin pitää avata portti...(ja avasivatkin)

Bysmyyr's avatar Bysmyyr (2017-04-03 23:06:42 +0200) edit
add a comment see more comments
0

En oo saanu mitään ideaa tähän. Ylläpidoltakin kyselin. Lopulta siirsin tuon halvalle vps:lle niin saa ite laittaa kaiken kuntoon...

Bysmyyr's avatar
196
Bysmyyr
answered 2017-03-27 11:20:18 +0200
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments
0

Kuten täällä on jo mainittu webpp1:een täytyy pyytää erikseen ylläpidolta portit auki. Lisäksi webbisivumuutoksen jälkeen .htaccessiin kannattaa lisätä rivi DirectoryIndex disabled sekä tietyissä tapauksissa myös DirectorySlash off

Kyselin ylläpidolta onko mahdollista proxyyn saada websocket-tukea. Päivittelen tiedon tähän, kunhan vastaavat.

jikuja's avatar
31
jikuja
answered 2017-04-13 17:10:27 +0200
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments

Your Answer

Login/Signup to Answer